Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell your MacBook

Remove/reset open firmware password macbook pro core i5

edited December 2013 in MacBook Pro
buying a macbook pro i5 but displays a closed padlock on top a space to enter the password and arrow. try pressing alt + option + p + r after increasing ram but not restart only shows me a folder with question mark and if I press alt just to format and is where the padlock appears ... use translator ... thanks for your help from mexico


  • Hi! Thanks for the post!

    Did you watch this video of mine?

    It sounds like you have the procedure right, but you must reset the PRAM 4 times in a row (initial chime, plus 3 additional chimes) immediately after changing the amount of RAM. If you power on the computer with the new RAM but do not immediately reset the PRAM, it registers the new amount and then you will have to change the RAM again. The padlock is proof that it still has the PRAM password in place.

    Also, I have not verified this procedure on newer MacBooks, and I have heard that it will not work on the newest laptops, so if you are still not able to remove it using this method, that may be the reason. In this case, you should be able to take your laptop to an Apple store, and they should be able to remove the password for you.

    Good luck!

  • Thank you for your response, this video is the one bring me here, in my macbook pro 13 i5 won't work, I change the ram and pressed the keys for PRAM but nothing happend is like the keys won't work, but I pretty sure is working good because I put a logic board in that case I use for i5. Can't use nothing I have almost a year trying a lot things even apple tell me is not stolen but I have no warrany I they charge me much money... I realy apreciate if you can help me, I can donate a fair amount, thank's again and sorry for my english, now I do not use translater, greating from mexico God Bless you All :)
  • Are you sure the RAM is good? You might want to try different RAM. You can also try it after adding RAM, and after removing RAM -- maybe you should try both, if one way does not work. If the PRAM eventually does reset, make sure to reset it 4 times, not just 1, because 1 will not kill the password.

    If there is a chance the keyboard is not working, have you tried connecting an external keyboard?

    If you can let me know the last 3 digits of the serial number I can look up the exact model and try to figure out if this method will work with your laptop. From what I have read, many of the newer models cannot be reset this way, and it's necessary to go to Apple for the fix.
  • Mr. John I follow all your steps and do not have warranty the mac any ideas, I look up in ebay and a few says they can unlook/reset the open firmware and in my country too, but I want to do it my self, other option is change de chip efi. what is your opinion?
  • Unfortunately I think I'm out of ideas. I don't have your serial number so I can't look up your machine. You may just have to take it to Apple to have it reset -- most people with newer laptops who have this problem have mentioned having to take it to Apple.
  • Hello John i have a macbook pro i just purchased on ebay. I have been trying everything on the computer and for everything i administrator name and password is required. I took a ram out of the the computer while trying to reset the pram and it automaiclally takes it to the lock screen. I need help please my macbook pro a1278 is driving me crazy.
  • Hi! A PRAM password lock will only ask for a password, so if it's asking for login and password, you're dealing with the operating system, not a PRAM password. (To make sure, power on holding down the option key and see if it shows a padlock and a password field -- if that's what you see, you have a PRAM password, but if there's no padlock image and it boots to the OS login, it's only the OS.)

    Again, if you're dealing with the OS login and password, the RAM procedure is not relevant and you just have to wipe the OS and reinstall the OS if the previous owner did not give you their password. If you don't have the reinstall media, call Apple and give them the serial and for $20 or so they will send you a replacement DVD.

    Hope that helps,

  • When i hold the option screen it show a lock with a field to enter the password right under it.
  • i hold the option when i power up and shows a lock. i try to install os x mountain lion and it ask for administrator name and password
  • Well, then you do have a PRAM password, but in your previous post you mentioned not being able to get past the administrator name and password fields, which indicates you were unable to log into the OS, because there is no login field for the PRAM password. Are you saying you don't have the PRAM password, and you also don't have the administrator password for the operating system? You may be facing both problems.

    I assume you've watched my really contains all the advice I have to give -- you need to change the RAM amount, then immediately reset the PRAM 3 times after hearing the first chime. And you have to do it immediately after changing the RAM amount, because if it powers on with the new amount of RAM, it will register that amount, and you will have lost your opportunity to reset it.
  • Yeah i watched it. i am completely locked out of everything on the computer. i had changed the ram for 8gb to 4 gb and try reseting the pram but it still goes to the lock screen everytime
  • Does it let you reset the PRAM, or does it go to the lock screen immediately and not let you reset the PRAM? If it doesn't let you, you might have bad keys on the keyboard preventing the 4 necessary keys from functioning, and therefore preventing you from doing the PRAM resets.

    I don't really have much additional advice. In theory the procedure should work. I'd take it in to an Apple store and see what they can do.
  • it goes immediately to the lock screen
  • So you're not even successfully resetting the PRAM then. I suspect a bad keyboard. Either that, or it's not detecting the change in the RAM amount. Try it when you put RAM in, and also when you take RAM out -- it's a change that matters, not whether it's more or less. Beyond that, you can try different RAM, because sometimes RAM is touchy. You can also try an external keyboard.
  • if i take all the ram out it doesn't power up it just makes a beeping noise what does that mean?
  • It means your computer has no RAM installed. You have to leave one module in, at least, because a computer with no RAM cannot operate.
  • i just left one in and press the power button then held down p+r+cmd+opt and it immediately takes me to the lock screen
  • See my previous comments -- I don't really have any more advice.

  • I was reading that the only way to pass it is by getting a keyfile from the hash and making into a bootable usb
  • I would just take it in to an Apple store. If it's one of the newest model machines it will likely have a different procedure that only they can do.
Sign In or Register to comment.