Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell me your broken computer

1 GHz TiBook won't start up

edited June 2013 in General
I've had my 1 GHz titanium PowerBook from new, about a decade ago and it's been very reliable. A couple years ago I got a cheap generic main battery from China. Never stellar, over the last few months battery life has really diminished and I'd get a total out of power shutdown (no sleep) at 85% charge. So I ordered a new battery, which hasn't arrived yet.

But yesterday I found the machine would not power on at all (Superdrive spins twice, hard drive spins, fans come on and stay on, screen stays totally black/unlit, no startup sounds at all).

There have been no hardware or software changes for years. I found that Control-Cmnd-Power combo (I think, I tried so many), worked once and then I backed everything up. I then did your PRAM disconnect/reconnect trick and it worked, but when I put the main battery back in, the machine would stop booting again. I then tried your trick while running with a constant wall connection, without the main battery and that worked, but each time I put the case back I'd again lose the ability to boot. I then tried without the PRAM battery at all, and that worked, until I put the case back on the machine would not restart again. Having done that a couple times, I couldn't get it to start at all, even with the case off.

I left it plugged into the mains with no PRAM or main battery for one last go and got a good startup chime, but no screen and all the other symptoms the same.

Each time I reset using the logic board button to the top right under the key board. Sadly I don't have an Apple power adapter to check the orange-green light. I have ordered a PRAM battery.

What else can I try/is likely to be the problem?

Should the machine be able to run properly without a PRAM battery? If it can't does that indicate something else is wrong? Is the main battery a distraction/irrelevance to troubleshooting?

I'm sorry if this rambles but I wanted to cover everything and really want this old machine to pull through... Thank you for a great site,

Christopher

Answers

  • edited June 2013
    Hi Christopher! Thanks for the post! Don't worry about "rambling" -- it's far better to have more information than not enough.

    Yes, a battery is a distraction...when troubleshooting it's always best to reduce the situation to the fewest components possible. That way you know extraneous devices aren't somehow clouding the issue. Once the issue is resolved, you can add devices back again one by one, until (hopefully) the machine is 100%.

    In theory, it should run fine without a PRAM battery. Without it, it won't "remember" any settings that the PRAM saves for you (time, screen brightness, etc.), but it shouldn't affect the machine's ability to power on and basically work. That said, Titaniums are a little weird, and given their tendency to be "jump started" via the PRAM battery trick, it may be worthwhile to see if the "new" battery helps.

    I would test your RAM slots -- power on with one slot empty, and then the other slot empty, and see if that causes a change. Titaniums are not as bad as Aluminums when it comes to bad slots, but the intermittent behavior you're experiencing makes me think of RAM slot issues, so it's worth ruling out. If the machine starts working perfectly with a slot empty, I'd just leave it empty, and put a 1GB in the working slot.

    You might try letting the computer sit overnight without the PRAM battery, AC, or primary battery (i.e. no power at all). Sometimes laptops, or power-related components of laptops such as DC-ins, get a "bad charge", and if the computer is left without power for a period of time this charge dissipates, and the computer behaves differently (better, hopefully) afterward. I'd let it sit overnight like that, and then immediately try the PRAM battery disconnect-reconnect trick.

    Beyond that, it's hard to say. I'd make sure all connections to the board are firmly seated. An Apple AC would help of course...it's conceivable you have a flaky DC-in, and an Apple AC might reveal that you are only getting a solid light when the AC plug is in a certain position. The 1GHZ Titanium is the DVI model, and it does have a replaceable DC-in, so you could try swapping it, although I don't necessarily have a high degree of confidence that's you're issue, at least without testing it with an Apple AC first.

    Anyway, good luck, and let me know if any of this helps or not!

    Thanks,

    John


  • Thank you very much - You've also given me a good triage plan there so I'll get on it. I found a bag of three new (but old stock) PRAM batteries online and hope that one is still in good nick.

    The PRAM batteries will take a little time to come, but I will check in again - thank you so much for writing that all out, it'd be great to keep this machine going. Chris
  • I've done some testing and am back. I tried booting with one RAM slot full, then the other, then neither and had the same result. I tracked down an Apple adapter and got the green light without the battery in and any flickering, so think the DC board is ok. I tried each of my three 'new' (used) PRAM batteries. One was good for one startup after a couple days charging, but then no further luck. I bought a multimeter and think that one of the three batteries has good voltage and have left that one in, but now haven't had a good startup for days. I'm careful to ground myself before working and I've not felt any sparks.

    I think that leaves a loose logic board connection or dead logic board. Are there any connectors I should particularly check? The only other detail I'd add is that I spent the last year working in a very hot and dusty environment. When the machine was on, so was the air conditioning, but when off and unattended it will have had a lot of time at high ambient temperatures.

    Otherwise I think its time to go new computer/logic board hunting, right? Thanks again,

    Chris
  • edited July 2013
    Hi Chris! Yeah, sorry to say it, but it's probably a bad board. The intermittent power issues usually indicate a weak or cracked trace on the board that only connects from time to time. This is often caused by ESD (electrostatic discharge). If you were to think of the traces on the board as roads, ESD is the equivalent of bad weather that erodes the pavement and causes potholes, and eventually leaves the roads completely un-driveable. It's not really possible to confirm this problem without a microscope and a lot of free time, but the "hot, dusty" environment definitely would point in that direction.

    You could always go through the procedure to remove and reinstall the board (guides are on ifixit.com) and see what you find, but since it's been your machine all along and nobody else has been under the hood messing with stuff, it's probably unlikely you'll find a loose connection that would account for the behavior. But at this point it can't hurt.

    I might have a Titanium kicking around that I could sell you cheap...if that's of interest, shoot me and e-mail at john@rdklinc.com and I'll see what I have.

    Thanks!

    John
  • I'm delighted to say I found a 1GHz logic board locally and am back in business. During the strip down I found a lot of dust and grit, so hopefully that was it and I'll be good for some time. Thanks for all your help, I now know where to come when I need more parts!

    My best,

    Chris
  • Awesome, that's great to hear! Good luck with the machine, and hopefully it will last you several more years.

    Thanks,

    John
Sign In or Register to comment.