Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell your MacBook

I messed up, Need Some Help with 15" 2008 Early MBP

edited August 2012 in MacBook Pro
Hey everyone!! For my first post im going to admit I made a mistake while replacing a CD drive with an HD adapter off of Amazon. Im a Tech so im not exactly a noob when it comes to tearing down laptops and upgrading them but i definitely made a noob mistake. Here goes. While multi-tasking i was replacing the top portion of the laptop which contains Keyboard, touchpad, power button , etc and i didn't notice i was putting it on backwards. So as soon as i plugged it in, the ribbon cable got warm so i knew i made a mistake. Now the laptop will not boot of course.

My question is , has anyone had any experience with this and if so is there a resistor i can replace on the board some where? Also, i cant get an exact model number because i can not find the serial number anywhere (It seems it may have been peeled). Any help is greatly appreciated.

Model is 15" Early Macbook Pro 2008

Answers

  • edited August 2012
    Hi! I'm confused as to what exactly was backwards...the topcase connector will only connect to the board in one direction. Regardless, I would first disconnect the machine from power and battery and let it sit overnight. Often a machine will retain a "bad charge" that will keep it from powering on, and once the charge has dispersed, the machine will once again power. If it doesn't, I would then disconnect the topcase completely and power on the machine by tripping the power-on pads on the logic board with a pair of tweezers. It takes some searching to find them, and at the moment I don't recall where exactly they are on your model, but they do exist, and they are usually labeled "power button". If you find the PMU reset, the power pads are usually within the vicinity.

    If that works, the issue can be blamed on the topcase. If it doesn't, we still don't know a lot. I'd test the RAM slots by attempting to power on with one empty, and then the other empty. Beyond that, it's a crapshoot between the left I/O board and the logic board itself. It usually makes sense to start with the left I/O only because it's less expensive. However, if you get a solid green light on the AC adapter plug, that is evidence the left I/O is likely good, and the board bad. I have never heard of a commonly faulty resistor or a fuse on 2008 Pros, so I wouldn't think that's a likely solution.

    John
Sign In or Register to comment.