Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell your MacBook

Hot wiring an Aug2011 17" Macbook Pro

edited June 2012 in MacBook Pro
Would you happen to know how to hot wire an 17" Macbook Pro purchased in August 2011? My wife spilled water on it, and it won't turn on with the power button. The Genius at the Apple store said he was able to turn it on, but he didn't verify if anything works beyond it just chiming. He suggested we send it to Apple to repair, but that we ought to back up the data first.

I could take the hard drive out and mount it externally on another machine (and just copy), however I'd like to try to power it on to see if it works, and try to run a Timemachine backup. Seems like a more reliable method than just dragging the files over. But I can't find any power pads, or a power symbol, and jumping pins 5-29 on the keyboard ribbon cable doesn't seem to work either. I'm out of ideas, help!

Answers

  • Hi Martin! I looked up your machine, and it appears the pads are in the far-left bottom corner of the board, just to the left of the RAM. There is a screw in the corner, and then just right of the screw on the bottom edge, maybe a half inch from the screw, is a small orange ribbon connector. The power-on pads are two vertical white dots between the screw and the ribbon connector. It does not appear that they are labeled.

    Make sure to disconnect the keyboard ribbon cable before trying to jump the board.

    Anyway, let me know if that helps, and good luck!

    John
  • I was able to obtain a service manual, and on this model, the pads were actually more to the right, a little southwest of the SMC chip. No matter which way I tried (battery plugged/unplugged, keyboard ribbon plugged/unplugged, external PS plugged/unplugged), I could not get it to turn on. Maybe something else fried in there. I ended up taking out the drive and using Clonezilla to grab an image of it and back it up to an external disk. I put the drive back in and now have it ready to send out for repair.

    Thanks,
    Martin
  • Good to know, and glad it worked out. All I can think of is to try jumping it with a paper clip -- sometimes screwdrivers or other tools you'd think would do the job don't end up properly bridging the pads for whatever reason. You can also try with the RAM in different configurations (one slot empty, then the other) in case it's a fried slot that is keeping it from powering.

Sign In or Register to comment.