Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell me your broken computer

Need help finding Power Pads to boot MacBook Pro without keyboard!

edited November 2011 in MacBook Pro
Hello, is there a way to turn my Macbook Pro "17 (2009) A1297 on without hitting the power button? I noticed that my keys and power button weren't working a week ago after spillage and drying it out. The lap top however turned on a week ago. I have been using it ever since without turning it off (using sleep mode), knowing that if I turned it off I wouldn't have a way to get it back on. Well, last night I accidently clicked to turn Shut Down from the menu and I can't turn it on.

I know that it is still working and in good condition, because I have been using it everyday, and all day for the past week since getting it dry and on in the first place.

I would take it in for service, but I don't have warranty on it anymore. I really need to somehow get it turned on before my upcoming tests this Friday.

I referenced you post on a matter for another MacBook, but different model on ifixit , in which you told someone how to short it back on with a piece of metal. http://www.ifixit.com/Answers/View/35169/Need+help+finding+power+pads+for+booting+without+keyboard,+can+some+on

Answers

  • On the 2009 unibody Pro 17", it appears the power-on pads are just to the left of the memory slots. So if you pop the back of the machine off and then position it so that the memory slots are facing you, you will see two vertical black screws just along the left edge of the RAM slots. You will see a pin between them, and just to the left of the pin you will see two vertical silver pads, marked R5015, and "PWR BTN" should be printed just to the left of the pads. If you bridge these pins with a metal object (I use tweezers...a stretched-out paperclip will also work), it should power on the machine. Please note, in many cases it is necessary to disconnect the keyboard cable before the power-on pads will function. When that is the case, you can re-connect the keyboard cable after the machine starts to power up.

    Anyway, thanks, and I hope that helps! Let me know how it goes!

    John

  • edited November 2011
    Wow, thanks for the answer and quick response! I will definitely look into this in a couple of hours. My brother has my lap top after taking it in for a look; he should be back after 11 CST, and I'll get back to you on what does or doesn't happen then (as soon as I try this)! I feel confident that this is the help I needed!!
  • Hey John,

    My brother got home about an hour and a half ago. Right away I tried this, and it powered on! Yay! :) Everything's working fine!

    So, I then played a video game (World of Warcraft) for about an hour. After playing, I exited WoW and remembered I was prompted when upon opening WoW the first time with an option to install an Apple System Update that would increase the performance of WoW. I then reopened WoW, was preompted with the message, and clicked install. The update installed and insisted that I restart the lap top...after shutting down, the system powered on with it's usual sound and the white screen and instantly powered off. Afterwards, I could not get the system powered on with this method.

    I'm thinking there will probably be some necessary repairs...is there anything I should try? or any more info you need about the system or situation to help? What kind of problem does this sound like to you?

    Thanks man,
    Stephen
  • What version OS does your machine have, and do you know what this specific Apple update was called so I can look it up?

    As I mentioned before, you might try disconnecting the keyboard ribbon cable before trying to jump the machine. It also couldn't hurt to disconnect the battery.

    I would also try resetting the PMU/SMC...this is usually done by holding in the power button for about 10 seconds while the power is off, and the machine is connected to AC. This causes the sleep light to flicker, and a loud tone to sound. It may be tricky to pull off with the power-on pads, but you can do it by holding a metal object on them for about 10 seconds. This is of course assuming the machine is responsive at all, but I'm hoping a reset will wake it up.

    It's odd that the machine powered off instantly. It almost sounds like something shorted it out electrically. You might want to look for loose cables, etc. When it has the bottom off, make sure it's not sitting on a surface that can generate static (carpet, cloth, etc.)

    If none of this helps, I would disconnect the battery and AC, and let it sit for several hours. If it starts working again, I'd try to get a replacement topcase fairly soon, because having these machines open is just asking for trouble. You can also try to open up the power button from inside the topcase, and clean the mechanism out with rubbing alcohol. Sometimes they just get stuck, and you can go in there manually and test the internal button (the button that the mechanical button depresses when you hit the power button) by pressing it yourself.

    Let me know how it goes!
  • Wow, okay this is a lot of good info. I figured I'd inform you with an update at a week's passing...which is tomorrow. I was able to get it up and running again; I unplugged (what I think is) the battery's cable from to the right of the memory slots, plugged in the AC, touched the pads, and it powered on. I then re plugged the battery cable and had the machine going until today :(.

    Today, I was using it as usual, when I noticed my "cntrl" and "up-arrow" keys start to press repeatedly (I'm using an external keyboard since none of the actual lap top keys are working). I closed the lap top to sleep it, opened it, and the issue continued happening.

    I thought maybe if I restarted it would be fixed. Thus, I restarted the system and the same error as precious occurred; as the machine turned on, before it even reached the white screen, it powered off instantly. This time, when I plugged the AC cable in the light was dim green...I have no idea what this means. I went about the same solution I tried before: unplugging the battery, touching the power pads, and nothing happened. Is the dim green light a bad sign?

    Where is the keyboard cable located? I have yet to try unplugging it and trying again.
  • From our last post, I don't know the specific version, but it is OS X (2009) and I don't know what the specific Apple Update was but it was running fine after I got it running and had it up for 5 days (minus closing it for sleeping).
  • edited December 2011
    The keyboard cable is the ribbon cable that connects to the lower edge of the board. It's the one that's about 3/4" wide.

    It's sounding like your machine has board defects related to power, in addition to the liquid damage on the topcase/keyboard (both problems probably caused by the same spill). I've had a couple like that, and they were very frustrating, and there was really no resolution to the problem. I ultimately had to live with the simple fact that the boards were bad. If you search eBay for "MacBook logic board repair", you can find people who will repair (or attempt to repair) your board for about $250, which is a better deal than buying a new one.

    You might try flipping the AC adapter plug over the other direction...sometimes that will cause it to go solid green. You might try testing the RAM slots, i.e. power on with one empty, then with the other empty. A bad slot that has RAM in it can cause a laptop to malfunction in all sorts of ways. And it could never hurt to try a different AC adapter, although that's probably not the issue.

    A lot of electrical problems can be resolved at least temporarily by removing all sources of power and letting the machine sit overnight, discharging whatever "bad charge" may be haunting the computer. So I'd remove the AC and unplug the battery and let it sit for a while. It sounds like the first time it started working again, it may have been a result of doing this, so I'd try it again. Unfortunately though, it sounds like a chronic power issue related to board damage. I'd be curious to see how much the situation would improve with a new topcase/keyboard, although it probably wouldn't resolve the dim light on the AC, or the sudden power loss.

    Have you inspected your board for corrosion? I'd use a flashlight, examine both sides, and if you find any, clean it off with q-tips or a soft toothbrush dipped in 90% rubbing alcohol. Let it dry, and see if that makes a difference. When there's corrosion sometimes that's all it takes, but it's hit or miss. I'd also check out the DC-in. These don't generally go bad, but if it's got corrosion on it, that could be a hint.
  • Hello, I am having the same problem as Stephen. I my son spilled water on my computer the power button stopped working. I gave to a friend that was able to start it using power pads unfortunately the mac went off, i forgot to charge it.
    So now back to zero it is not starting. I wasn't there when he did it and Im unable to get in touch with him. Can you help me locate the power pads on the 2011 MacBook pro 13"
  • Hi Cleef! Unfortunately I don't have a service manual for that model, since it's fairly new, so I can't give specifics. Perhaps someone else will see your post and comment. However, I will say that they are usually very similar -- two silver dots in the area around the left-bottom corner of the board (once the machine is upside-down with the bottom off), or around the left edge of the RAM slots. Sometimes they have a small power indicator icon next to them, and sometimes not.
  • Joining (really newbee Macs):
    Hi guys. John you are a God send, I have been looking for those power pads for days now on the very model you describe. 17" (2.8) Almost since new in 2009 we soon got a start up problem (as I read hundreds if not thousands of others report similar. Mac should have recalled). I am NOT convinced it is the logic board though. We tried all the web suggestions we could find, sleep etc. Still same problem.

    Mac dealer 'immediately' suggested a logic board problem, but until now we have always managed to power on after a few very tedious tries, but we did always get there. However, since they looked at it, no power at all gets through now. Dead.. a no no.. kaput and yet they say they did nothing only tested the Mac and didn't open it up, but we don't believe them. They are complaining and suggesting that the replacement copy battery we bought caused the problem. That is utter rubbish, because we only bought/replaced the battery because of the problem in the first place, but they did report that the old battery was ok. Who knows

    Did the procedure you outlined, with the power pads, but did not work. (I am not sure which is the keyboard strip, but disconnected the plug nearest to PWR Btn pads and removed battery, but no luck.)
    Do you have the pin out connections to test the Mag connector, through to the little plug which goes to the Logic board? I have now removed the logic board to get to this little circuit board. (Even continuity to the power on button but I guess if the pad attempt didn't work, the the power button is irrelevant at that stage).
    I do suspect this little board or the mag connector inside..


    Now: Green light is on - on the Mag connector. Orange very rarely, but sometimes it will glow orange if I hold down power button for over 30 seconds and then plug in Mag. (But not always.. mostly just goes green immediately)..
    As I said, we have changed batteries etc, and 'before' when we did manage to boot, the Mac said the batteries where fully charged, but as soon as we disconnected the power chord, the Mac would shut down and then we had the same old fiasco all over again.
    Anyway.. now the baby is dead. Tears! Any ideas?
  • Thanks for the kind words!

    DC-ins (the MagSafe connector) usually don't go bad, unless liquid gets directly on them and they become corroded. From what you describe, I wouldn't suspect it. I wouldn't suspect the battery either, although for testing purposes I always recommend removing the battery, just to simplify the situation.

    When you say you eventually get it on, how are you doing that? Just pushing the power button repeatedly?

    I would test your RAM slots by booting up with one empty, and then with the other empty. A bad slot that is populated will cause the computer to behave in a lot of different ways, including as you have described, and the behavior is often intermittent and then eventually permanent as it gets worse. But then when the RAM is removed from the bad slot, the problem sometimes goes away entirely.

    Some of the larger unibody machines don't have power-on pads, and while I don't have a service manual for your particular machine and am therefore not sure, I wonder if yours might need to be jumped as shown in this article:

    http://www.ifixit.com/Answers/View/79225/Where+are+the+power+pads

    Another idea, although unlikely, is that you have a stuck power button. You can disassemble the power button assembly and push the inner button directly to rule that out.

    No, unfortunately I don't have the pin-out for the DC-in...I don't usually deal with things from an electrical angle, since it's difficult and rarely conclusive. I prefer to use a process of elimination by replacing parts.

    Anyway, good luck, and let me know how it goes!

    John
  • Thanks John, (sorry for delay, we had no network for a day or two here. The demonstrators burned one of the telco nodes).

    First answer to how did we start our MAC: Well, this trouble began about 6 months into the machine's life. (Yeah, we sent it in but they said it was software). One day it just powered down half way into the power up cycle, round about the Apple sign. Yes, you are correct, eventually, it would always switch on but we had to repeat over and over until it decided it had had given us enough anxiety and was going to let us boot. Bulletins boards etc duplicate the problem and most suggested the Operating system, even battery. Got a new one, same same. Got new power leads and mag. Been there, done that, back installed and different versions of the OX, made no difference. At one stage we upgraded the SSD and same same. Memory removal, even back to known good. Same same.
    So we sent it to the Apple agent and they didn't even look at it at first, just said it was the logic board and that replacing the battery with a non Apple part caused this problem. I disputed that with; " We replaced the battery because of the problem and If it boots eventually and will stay on for years, if we don't switch it off or close the lid, then just maybe it is not the logic board, but a dry joint on the power line in."
    They didn't like my suggestion much but said they would look at it again. We left it with them for two days and they came back with the same. Only difference: Now we get NO POWER ON at all. Press the start button as much as you like.. no go. (They did test the battery and said it was ok, even the original). We called, to tell them that they had now made it worse and they ignored us.
    So I read your post along with Phillip Garrison's bits on here:
    """MBP doesn't power on; Power Pads location on MacBook Pro 17" A1229?"""

    I tried the pads as I said and nada, nichts, no go. Now the beast is dead. Gingerly, I took out the motherboard to get to the MAG input board and the board plug underneath. I seated all well. (I do know the voltage at the MAGSAFE connector, but after that, who knows what happens at the board connection underneath as that little circuit has some devices on it.

    Put it all back together, but having big trouble with re-plugging (sliding in) the hard plastic ribbon cable under one of the little steel covers you have to remove to unplug the cables. The tiny weeny plastic lock bar broke off. (It is the left one as you look at the board from the battery side. Is that the keyboard?)
    Anyway, expecting a miracle... No way, I am unloved. DEAD mate.. DEAD AS.. not even a flicker.
    (I am now trying to fathom that link you posted above.. see if I can locate it).

    Cheers./
  • edited February 2013
    Sorry for the delayed response. It does sound like the board. Did you try the method of jumping the board in the iFixit article? I have a feeling your particular machine does not use the power-on pads, but rather requires the other method, i.e. bridging the pin on the trackpad cable and the ground. If you have a sticky power button, it would make sense that the machine stays on once it powers up. They keyboard is the black ribbon cable, about 1" wide. Without the lock bar, you're going to have trouble securing it...you might be able to tape it in place. The ribbon cable needs to be disconnected before jumping the board.

    I usually tell people that the DC-in (inner MagSafe board) is not typically the culprit, but if the iFixit jumping method doesn't work, it couldn't hurt to try replacing it, since it does sound like a power-related issue.

    Another thought is to verify you have a working AC adapter, and that it is 85W and not 60W. An underpowered AC adapter will often fail to power a machine, so that's a possibility.

    Anyway, good luck!

    John
  • Tks mate.
    I fixed it. As I didn't hear I just assume the logic board, but I still feel the major part of the old board is perfectly ok, just the power up logic screwed somehow.

    Anyway, I got a logic board for 540 dlrs and just in case a magsafe board and put it all in. Everything ok. EXCEPT no microphone now. I have NO idea where that is and I guess I must have dislodged some wire somewhere in all the tear down. Maybe you can guide me to that. I am looking at videos on Ifix it, but so far I cannot find any info.

    Taking the board out was fiddly and to say the least delicate and I never thought I would get away with it, but I did. I actually dismantled the logic board about 10 times or more before I fitted the new one. I became a bit of a blind expert. I was just trying various things to see if I could get those pads to work on the old. NO way!!! Maybe if I tear it down again, I will try your suggestions.

    Even with the new board installed, I forgot to clip on that little flat cable that powers the keyboard lights. In fact, I had no idea what that did until we booted and discovered no lights. I wracked my brain and then I remember that little sod of a flat flexible thing which hides under the board if you put a new one back in.

    Just can't remember seeing a microphone cable.. As I said, I don't even know where the mic is on the unit.

    Geg
  • Hi Geg! Sorry again for the delay. Glad to hear you got it working!

    Yeah, the keyboard illumination cable is always easy to forget. It's so small, and it often gets stuck underneath the board when you put the board back in, so it's easy to overlook it.

    I'm not an expert at the 17" unibody models, but generally the microphone cable is attached to the right speaker assembly, which is the long black plastic thing (when the machine is upside down, it's underneath the board on the right side). My guess is that while putting the board in place the cable came loose, so you might have to go back in there, remove the speaker assembly, and make sure the microphone cable is in place and fully seated. Here's a page of an iFixit guide related to removing the speaker assembly, and it should give you an idea of where the microphone cable is:

    http://www.ifixit.com/Guide/Installing+MacBook+Pro+17-Inch+Unibody+Microphone/3445/4

    Anyway, hope that helps!

    John
  • Well tremendous John. Again, thanks for the help. That looks to be the exact part.

    I kept popping back to see if you posted. I don't know how to get notifications on this bull board.
    Anyway, meaning to do it 'first', I was a bit hasty and excited to see if this Mac was going to work, I completely forgot about that oblong box you talk of which looks like a couple of speakers. It dawned on me after the Mac booted and I thought there would be no sound, but there is. Sound is fine, so assume oblong black box was already on replacement logic board (Stupid me, it just went clean out of my mind in the curiosity). Then again, I wondered where the 'left' speaker is. Another mystery because there is NOTHING attached to the logic board that I can see, unless it is some very clever little wizard Japanese thing, now built by the Chinese.

    Bottom line, I will take it apart again and look, but I aint in too much of a hurry to do that, plus Eva Braun who actually own the beast (wife) will not let me do it in any hurry. I will eventually though because it is bugging me and when I do, I will post here.

    By the way, I have a sort of service manual which ''''seems''''' to be for all the Macpros from about 2008 to 2010, A very loooooong PDF job which I downloaded from a post somewhere. (Maybe here and it was you who posted it). Very handy but a bit tedious finding the relevant model. (you probably have it, but if not, I am very happy to send it to you if of interest.

    Geg
  • Like the heatsync, the speaker/microphone assembly is not usually included when you buy a replacement board, and it is affixed to the board you take out, so it's easy to forget to transplant it to the new board. And even if you do, the small connectors often come loose in the process of putting the board into the machine. The microphone in many models needs to be positioned over a small circular grate so that it can "hear" sound from the outside, so failing to get that in place often means the microphone will be very weak, if it works at all.

    I haven't dealt with too many 17" unibody Pros, but the left speaker is usually in a black plastic component that runs along the top edge of the optical drive.

    Anyway, good luck, and it sounds like you're most of the way there!

    John
Sign In or Register to comment.