Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell me your broken computer

Macbook Penryn model...can I use a downgraded logic board?

edited October 2011 in MacBook
Hey John,

Very new to these boards and new to repairing Apple products. I have scanned your whole answers forum...love what you have done, good job! Anyway, I picked up a macbook penryn model from a buddy that wanted it repaired and took it apart. The logic board definitely had some water spilled on it (no idea how long ago). Plenty of oxidation and electrolysis on the board. I am going to get a soft tooth brush and q-tips with isopropyl alcohol and see how far that takes me.

If that doesn't work, I will have to replace the board. The model number on the board is the 820-2279. My question is, do I have to get the 2.4 GHZ logic board again? That is what he had. Can I downgrade to a different board? (I am trying to spend the least money on a new board.)

Any help or links to ebay auctions would be awesome. Also, if you have any suggestions on how to bring the computer back to life; let me know!

P.S. - All of the oxidation and electrolysis is on the bottom left of the board, right where you connect the batter power. Thought I would let you know in case you had any ideas.

Thanks in advance.

-Taylor

Answers

  • Hi Taylor! Thanks for the kind words!

    I don't know if you've watched the A1181 board overview video that I have in the Tutorials section, but if not you might want to, as if gives a general overview and will provide all the info you need as far as what to replace it with. In short, your machine can use any 820-2279-A board, from 2GHZ to 2.4GHZ. But when I searched for 820-2279-A on eBay, it did not seem that 2.4GHZ were going for cheaper than any other model. In fact LaptopAid (eBay's best and cheapest parts vendor) had the 2.4GHZ cheaper than other people were selling the 2.2GHZ, just over $200.

    Cleaning the board as you mentioned is the correct first step. Remember to let it dry before powering on again. But also, are you seeing any light on the AC adapter, hearing any chimes or beeps, screen lighting up, etc.? Have you tested the memory slots by powering up with one empty, and then the other empty?

    Good luck, and let me know what happens!

    John
  • Thanks for the speedy response. The parts are currently drying on a paper towel.

    Before I took it apart, when I did plug the AC adapter into the magnet port I would get a very solid green light and then about 8 seconds later get a dim green light. The laptop would power on so I could see the bright white apple loading screen. I could then go to the desktop, but as soon as I moved the trackpad or keyboard or anything, the computer would go into sleep mode. All the research I have done points to a faulty logic board.

    Also, I would here the chime/beep for boot start-up and I have not tested the memory slot. I will test with one empty and then the other if cleaning doesn't work.

    When do you think I can put the laptop back together and power it on? I finished cleaning all of the parts last night at about 10 PM PST.

    Also, I accidentally yanked to hard when I was taking the keyboard off and ripped that little keyboard cable (I have already bought a new one ebay for $8.75), Is there a way I can power it up without that cable or should I wait until it arrives?

    Thanks again John!



  • Yes, without the topcase, you can trigger the power-on pads on the board as discussed here:

    https://www.rdklinc.com/answers/discussion/comment/189#Comment_189

    I'd say your board should be dry by now, unless you absolutely soaked it in alcohol. If you did, I might give it another day.

    Wow, your machine is closer to working than I realized! A1181 topcases are fairly sophisticated and contain some sleep-related hardware that can get damaged by liquid, and cause a machine to go to sleep as you mentioned, so it will be interesting to see if the new topcase will improve the situation.

    I wouldn't worry about the dim light unless it persists after powering on again. Try without the battery connected and see if that makes a difference. Even if you still see the dim light, it may be due to the need for a new battery connector, which may have been damaged by liquid as well (you can usually tell just by visual inspection). They commonly fail, and if you replace it, remember to get the Energy Star version, which has a gap in the pins (as opposed to the earlier version, with no gap). Also, A1181s need a firmware update to work correctly with the newer AC adapters that have the L-shaped connectors, and although they generally function fine without the update, I've noticed some funky Ac adapter light coloration (or lack of light) until the update was applied. If you machine doesn't have the update, you can get it by running Software Update once the machine is working.

    Anyway, of course all this is hypothetical, and we'll know more once you power on again and try the topcase, so let me know how it goes!

    John


  • I just checked on the parts. They seem dry as a bone, but last night when I was cleaning it I did dip a toothbrush into alcohol and scrub, not sure if that is considered "soaking the board in alcohol".

    Also, I think you misunderstood, the top case is fine. The little cable that connects to the motherboard is the thing that I broke, so I ordered a new one of those.

    Can I still use the power-pads trick with a flat head screwdriver?

    If you think it is safe to go ahead and start to assemble the pieces again, I will.

    Just let me know!

    Thanks for all your help by the way.

  • No problem!

    I think it's dry enough.

    Still, I've seen topcases cause sleep issues, so if the cleaning doesn't make it go away, the new topcase might.

    Yes, a flathead screwdriver should work. I usually use a pair of metal tweezers, but any number of tools should do the trick. If one doesn't seem to work, try another before giving up.

    I don't know which end of the topcase cable came off, but if it's the topcase side, you can peel back the rubber square cover on the underside of the trackpad, and there is a socket that the cable goes into. It may just have come out of the socket, and could possibly be re-seated if that's the end with the problem.
  • edited October 2011
    The pins snapped off the end of the cable that connects to the motherboard. So, I will have to replace that and have already bought a cable on ebay. Should be here in a couple days.

    Can I put the computer back together and power it on via the power-pad trick without having the upper case cable connected to the motherboard? Or should I wait until it arrives in the mail?

    How will I control the computer than without the keyboard and mouse?

    I hope that I am explaining things correctly.
  • Ah, I get it, so you haven't ordered a whole new topcase. Well, hopefully cleaning the board will make the difference.

    Yes, you can power on without the topcase connected. In fact, if the topcase is connected, the power-on pads are inactive, so it's meant to be done with the topcase off. You can definitely try it now.

    You won't be able to control it unless you have an external USB mouse and/or keyboard. But even without those, hopefully you'll be able to see if the previous behavior continues.
  • Excellent. I will go ahead and put it back together tonight and either respond tonight or tomorrow morning.

    Thanks again for your help. I will let you know how it goes. Cross your fingers!
  • So, I just finished installing the motherboard back in and connected all the different cables to the motherboard. I did not connect the battery or the battery connecter to the motherboard.

    I plugged in a magsafe power supply to the motherboard. I got a very dim green light at first and tried to do the power-pad trick and got nothing. I pulled out the magsafe power supply and plugged it in again. I got a solid amber light, tried the power-pad trick and the laptop booted up. I then got a solid white screen with an Apple logo and a spinning dial for about 3 minutes. It then went blue and then black and the fan stopped spinning on the heatsink. The laptop went into sleep mode so I did the power-pad trick again and I got to the OS login screen. The mouse came up and then as soon as it came up the fan on the heatsink stopped spinning and it went back in to sleep mode. It did this all night while I was testing it.

    I then proceeded to swap out the memory in each slot. Booting with 1 stick in and the other out and vice-versa. Same thing happened...I would get something on the screen for about 3 seconds and then back to sleep mode (heatsink always stopped spinning a few seconds after the screen went black).

    I have run out of ideas...what say you, any other ideas??
  • Have you put the heatsync back on the processor, and if so, is it properly secured, and did you clean off the old thermal paste and replace it with new thermal paste? You machine could be overheating...an A1181 will survive anywhere from 10 seconds to 3 minutes without a proper heatsync setup.

  • Wow, I had no idea about that. I will go ahead and scrape the old thermal paste off and apply some new paste. I also didn't secure the logic board to the case because I didn't think it was necessary for testing, but I did secure the heatsink to the processors.

    If this doesn't work, what do you think the problem is?
  • edited October 2011
    It's not necessary to screw the board down to the case, but it is a good idea to at least have the board in the case, because if it's out there are too many pieces of metal around and it's too easy to short out the board.

    If correctly connecting the heatsync with thermal paste doesn't work, then I'd guess the board has probably sustained damage that is not going to be realistic to repair.

    One think to try is booting off the OS reinstall DVD, and seeing if the machine behaves the same as it does booting from the hard drive. It's a longshot, but you have been basing all this on booting from the HD, so if by chance something about the HD or the OS installed on it is the problem (not likely) then this will troubleshoot that.

    But unfortunately, often there is no easy answer. A lot of the time it gets to the point where, if you're not an electrical engineer and an expert solderer, you just have to throw in the towel, and spending more time on it is no longer productive.
  • I will try both of those things and get back to you within the hour.

    Thanks for your responses. I may just have to go with a new board for this guy.
  • Re-applied the thermal paste and tried to boot it up. Same thing happened. I also tried to boot with a snow leopard disk in and got the same thing.

    Looks like I will be buying a new board...unless you have any other ideas...

    Also, how can I get that disk out? Keep in mind I don't have a keyboard connected.
  • Sorry to hear that.

    Once you have a working topcase, if you hold the trackpad button down while powering on, it will kick out the DVD.
Sign In or Register to comment.