Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell your MacBook

MacBook firmware issue

edited October 2011 in General
Hi John,
I acquired a MacBook Pro 5.5 with a different issue then I am used to. In this case the previous owner believes they "bricked" this MacBook Pro after an Ubuntu install gone wrong. The computer starts with no screen and the sleep light blinks and there is a beep. Do you have any advice for reloading the firmware? I've been trying to read more about it but wanted to get my facts straight before trying anything out.

Thanks for your advice. This site has saved my butt and a few computers a handful of times now.


  • edited October 2011
    Hello! Thanks for the kind words!

    Do you know anything about this "Ubuntu firmware" the previous owner installed? This may just be a topic unfamiliar to me, but as far as I've ever been aware, Ubuntu is purely software, and I don't know of any Ubuntu-related firmware that works on a Mac. Unless there is some sort of firmware hack out there that assists Ubuntu?

    I've never heard of a "bricked" Mac, although I suppose, like any other device, if you interrupt a firmware update, you could permanently damage the board. I've only ever installed the typical Software Update firmware upgrades, and I've never heard of them killing a computer.

    Anyway, in the absence of specific knowledge about this, I would probably troubleshoot it like any other machine. By "no screen" do you mean it's black, or white? Does the screen flash when you power on? Does the sleep light blink any specific number of times?

    If it's making a single beep, that could indicate a RAM issue, and potentially that there is no RAM installed. If there is RAM, I would test the slots by power on with one slot populated and the other empty, and then with the other slot populated and the second empty.

    You can also try resetting the PRAM and the PMU/SMC. But from the symptoms it sounds like a RAM issue.

    Also, if it's not a RAM issue, I'd go to the Applecare website, plug in the serial number, and see if it's still under warranty. A surprising number of used machines are, in which case Apple might take care of the issue for free.

    Good luck, and let me know what happens!

  • Thanks John,
    This is what the previous owner details happened:
    So I spent a day becoming somewhat familiar with it and decided to install Umbutu for dual booting.
    On my PC I downloaded the [ubuntu] 11.04 iso, and used the USB installer program to put it onto a 4GB USB stick (I let the application format my flash drive)

    I had previously opened BootCamp Assistant in Utilities and made a 30GB partition for "Windows".

    So I ALT booted into EFI boot and went through the "Install Alongside OS X" installation. Everything seemed to work great and at the end I clicked to reboot and finish. It rebooted and asked me to remove disc's and external drives and then press enter.

    As soon as I did that and pressed Enter, the screen went black, the led light flashed a bunch and let out one long beep (about 3 seconds) Then nothing, just black screen. I have been searching for hours. Everything I see about those beeps would call it a RAM error. If I turn off and back on, it doesn't let out the beep again, or flash the led light/ light just stays on while screen stays black

    Thing is, until just a few minutes ago...every 5th time I tried to boot, it would go into Mac OS X like nothing was wrong.

    So finally, I waited until my 5th boot, and ALT back in to try to reinstall the Ubuntu package. This time, the top option was to delete all the ubuntu and reinstall it fresh.

    Now, I don't even get my 5th boot into Mac OS X, I just get the first boot with the long beep, 4 boots of nothing but black screen, and the 5th boot is the long beep again.

    Me talking again:
    I found one with similar problem, and it's what I will try but I wanted to check with you first, as my go-to repair columnist!
  • edited October 2011
    Weird, that link didn't seem to work. Here's another interesting link:

    I still don't know much about this and could be wrong, but it doesn't sound like the firmware is being affected, and it's likely just a matter of various partitions existing and the computer being confused about which to boot from. Have you tried powering on into option mode? The article seems to suggest that that always works. Also, resetting the PRAM and PMU/SMC? The article above suggests that as well. Have you tried booting from restore media and wiping the drive? Also, I would definitely verify that the machine definitely does have RAM, and that the previous owner didn't pull it.

    I haven't put Ubuntu on a Mac, but I have used external Firewire drives that had several bootable partitions, and Macs definitely do get confused about which one they are supposed to boot from. Resetting the PRAM and PMU/SMC in those situations did seem to normalize the behavior somewhat. And powering on in option mode helps because it gives you a list of all bootable partitions and lets you choose, relieving the computer of the task of picking for itself.
  • Thanks for the tips. I'll begin tinkering tonight and will let you know how I make out.
  • edited October 2011
    Another idea -- try disconnecting the hard drive, and powering on. If the computer behaves normally when the hard drive is connected (chime, white screen, blinking folder), you know that the problem is confined to the hard drive and its partitions, and the booting issues. But if you still have a black screen and a beep, even with the drive disconnected, then you know it's a hardware issue with the memory, board, or the firmware (if in fact there is some sort of Ubuntu firmware installed).
  • So I tried your tips and unfortunately I could never get the device to boot to POST...Just a sleep light, spinning hard drive and every third boot some action from the SuperDrive. Either the EFI is really tanked or coincidentally there is a hardware failure as well.
  • Hmmm...well, if you've tried everything I suggested (removing the hard drive, testing the RAM slots, etc.) then I don't know what it could be. I'd verify it's not under warranty. You might also try taking it to the Apple store. I'd ask if it's eligible for a Depot repair...if so they'll probably swap the board for about $300. Depot is a company associated with Apple (possibly even owned by them) that refurbishes their computers. They don't offer Depot repairs to everyone, but I find that if you ask for one they generally allow it rather than reject you. The significance of Depot is that they are very inexpensive compared to Apple, which always gives totally ridiculous price quotes.
Sign In or Register to comment.