Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell me your broken computer

Dead Macbook A1181 (Late-2007)?

edited October 2011 in General
Hi!
I just purchased a used macbook off of a buddy of mine. His hard drive crashed and he ended up just going out and buying a new mac. So I went out and purchased a new hard drive for the machine and started it up. I managed to get snow leopard installed, then things started to go south.

First, when clicking on the trackpad "button", it would register as a "secondary-click"; constantly opening up little menus all over, no matter what i clicked on. And then out of nowhere, the keyboard stopped working. The caps-lock button remained lit, and even pressing that there was no change to the light.

I didn't have time to really mess with it so i left it open, not connected to any power, and went out for a few hours. When i came back the mac had gone to sleep. The white sleep light was going on and off, so i tried to wake the machine. Nothing. I plugged it into power, nothing. So i took the battery out and placed it back in, connected the power supply and tried to power it back on. NOTHING! No sounds, no humming, no fans, NOTHING! When connecting the magsafe it will light green, and then go to amber as if it were charging, but still nothing on the mac starts.

So now I'm not sure what my options are here: should i assume it's the logic board? something regarding the magsafe adapter? a faulty keyboard? water damage?

Any help?
Thanks in advance,
Mike

Answers

  • edited October 2011
    Hi Mike!

    I wonder if your topcase connector inside the computer may have come loose and/or disconnected. I'd take it off and re-seat it. A loose connection could account for most of the quirky behavior you're seeing. If you go to ifixit.com and look in the guides for the A1181, you'll find one for removing the topcase.

    The battery sits beneath the button and provides some resistance against it, so without the battery in, the button can be a little "softer" than it would be otherwise. The button behaving as if it is permanently depressed can occur when the button gets stuck in position, and often this can be resolved by pressing upward directly against the battery from inside the battery compartment (this can also help reverse the "soft" button issue).

    If re-seating the topcase connector does not help, you can take the topcase off, and trigger the "power-on pads" on the logic board. These are two metal dots on the board which, when connected by a common piece of metal, trigger the computer to power on. Make sure the topcase is completely disconnected, or the pads will not be active. The location of the pads is shown in this link:

    http://www.ifixit.com/Answers/View/35169/Need+help+finding+power+pads+for+booting+without+keyboard,+can+some+on

    If that works, you know the topcase is at fault. I've found the pads to be temperamental, so if that doesn't work, I wouldn't give up before trying another topcase. You can get them new on eBay for $30, and used for even less. If your topcase has any cracks around the sides and front, you can take the computer (make sure to put it together first) to the Apple Store and they will replace the topcase, since they consider the cracked plastic to be a design defect. Who knows, depending on how nice they feel like being, they might replace the board if they discover that the machine does not power on with a new topcase.

    Good luck, and let me know how it goes!

    John
  • This is such a huge help thanks a ton John! I now have hope for this machine again! I'm working the next ten hours but when i get home I'm going to try re-seating the topcase. Will let you know how it goes.

    Thanks a million!
  • GREAT NEWS!

    I took the top case off and went ahead to check power on the logic board. Using a flat head i connected the two power pads and it started right up! The top case underneath is extremely dirty with hair and dust, along with everything on top of the logic board. I'm on my way to target to pick up some compressed air in a can and contact cleaner and reseat the top case.

    Will get back to you with an update shortly. Thanks again!
  • That's great to hear! Compressed air is good, and if there are areas of the board where it's really caked on there or hard to remove, you can use 90% rubbing alcohol and a soft toothbrush, soft cloth, or q-tips. Just make sure to allow an hour or to so dry before powering on again. Anyway, I'll keep my fingers crossed, but it sounds like you might have a working MacBook again before long!
  • I cleaned and dusted everything off, even used contact cleaner on the ribbon from the top case to the logic board; let it dry. I attached it back on. I plugged the magsafe in and it turned amber right away. I flipped it over and looked at the battery indicator to see if it was charging, but no lights were on? Then i went to go power it on and still nothing.

    So it must be the topcase like you said. I called apple and told them about my recent purchase of the used computer. The woman switched the registration of the product into my name and she set me up for an appointment at my local genius bar for 1pm tomorrow. She said there should be no problem for them to replace the topcase and the display bezel on the machine free of charge.

    I just wonder if the apple genius will go to power the machine on and have a problem replacing the case?
  • edited October 2011
    Hard to say, but I doubt they would refuse to replace the parts, because I don't think the policy says anything about whether the computer is working or not. I've generally found that honesty is the best policy when it comes to taking stuff in...if you tell them everything you've done and that the topcase seems to not be working (in addition to having chips), they will be better informed and more likely to help. I can't imagine even if they decided not to give you a topcase that they wouldn't be willing to at least let you try another one...and then if it works, they would be obligated to give it to you! :-) And you can always say in your defense that you triggered the power-on pads and it worked, which means it is in fact a working computer.
  • Well I went to the genius bar this afternoon. I was honest with the guy and told him everything that was going on with the machine. They approved the replacement of the top case and the display bezel, for free! When I went to pick it up, it powered on no problem. When the tech came out to give me the computer, he told me he was impressed with how i jumped the machine via the power-pads (thanks john!) and that he has never seen anyone do that by themselves before.

    I couldn't be happier, neither could my girlfriend, whose ultimately getting the mac lol. The machine works great now. The only minor quirk I have with it now is that there is something "if-y" going on with the backlight of the display. 90 degrees plus of the screen open is fine, anything less that 90 degrees the backlight kicks off, but if I look at it in the light i can still see the display.

    Any thoughts?
  • That's great news! I'm really glad to hear it worked out!

    A dead backlight can be the board, the inverter cable, the inverter, or the screen. It's almost never the inverter itself. It's usually the screen going bad, but the fact that it goes on and off when you tilt the screen is a very good indicator that the inverter cable is at fault. This is about a 3" cable that goes from the inverter at the base of the screen, through the hinge, and into a socket in the upper-left of the board. What often happens is that the cable gets crimped in the hinge, and so moving the hinge can tug at it, or smash it, causing the outage.

    There's a good change you don't need a new cable, and you can re-position it so that it's not being crimped. To get to it, you need to take off the topcase, take off the screen bezel, pop off the hinge cover with a screwdriver, and then remove the upper part of the left side of the screen hinge (a piece of metal with 3 screws in it). There should be tutorials on ifixit.com showing how to do all this. Once you've done that, you'll have access to the inverter cable on both ends and be able to do what you need to with it. Keep in mind there is a screw connecting the cable to the underside of the screen...this helps prevent screen movement from tugging at the cable, so it's important to put that screw back in place. Sometimes people get lazy and don't put that screw back in, which could potentially cause the issue you're experiencing.

    If you do need a replacement, the inverter cable is a $20 part on eBay, and there are two types: 3-wall, and 4-wall, and they match 3-wall and 4-wall sockets respectively. The 3-wall is a flattish connector that is mostly used in Core 2 Duo machines, and the 4-wall is a chunkier connector that is used mostly in Core Duo machines. If you go to the Tutorials section of this page, check out the A1181 logic board overview video, and it will give you a rundown of all the various boards and which have what connectors. This might help you identify your board and therefore which cable you need. Or, you can just pop off the topcase and look at the logic board end of the cable to see whether it's 3-wall or 4-wall.

    I think I've made it sound horribly difficult...it's not really...it's just a few steps beyond where you've already been when you took off the topcase.

    Anyway, congrats again!

    John
  • Hello to all. I liked the site, an important method to help Apple users. Unfortunately I found the site after buying a new logic board.

    I have the same model late 2007. My city is in Brazil, she is very hot. On a beautiful day my Mac hung up, left a burning smell and did not work anymore. I not spilled anything on it, simply hung alone.

    I wonder if the excess heat can ruin the logic board, or topcase that spoiled yourself?

    PS: The MagSafe light illuminates.
  • Hello, and thanks for the post!

    So when you try to power on, you get nothing, no chime sound or light on the screen? I would remove the battery and try again. And then I would try again with a different AC adapter -- MacBook AC adapters are notorious for catching fire and burning up. I wouldn't necessarily expect it of yours if you still get a green light on the AC, but it's worth trying regardless.

    Beyond that, I would remove the topcase (you can use a guide on ifixit.com) and see if you can jump the board with a screwdriver or a pair of tweezers by triggering the power-on pads. In your model, they should be just below the fan, and you'll see a power indicator graphic. Doing this will let you know if the topcase is the problem, or the board is the problem. I would also spray off the board with compressed air and examine it for any corrosion or damage. If you find any, you can clean it off with a toothbrush and 90% rubbing alcohol, and see if it works any better after it dries.

    If none of that helps, you've probably just got a bad board, and A1181 boards are really worth repairing at this point, since you can get them on eBay for $80. I wouldn't suspect the DC-in, because a DC-in that shows green is good 99.99% of the time.

    Hope that helps!

    John
  • Hello John, My old logic board was really burnt.

    My new logic board arrived, i installed on mac, now starts normally. Also my top case is working.

    But unfortunately my video screen does not want to display the image. Only a weak lanpejo appears. When illuminated with a flashlight you can see the Apple brand, and nothing more.

    I do not know how to solve this problem. I have found no solution on internet.
  • Hi! When you flex the screen back and forth, does it ever light up?

    The first thing I would check is the inverter cable on the side of the board. Most 2007 models have a 3-wall cable which is very thin, and it's important that it's firmly seated in its socket (in the upper-left corner of the board, just below the left hinge). Also this connector has 4 cables that go into it, and any of these 4 cables can be loose. If you see that any of them aren't secured, use a fine-point pair of tweezers to push them back into the connector.

    Beyond that, you might be looking at a bad inverter cable, bad screen, or bad board, but hopefully you'll find that it's as simple as re-seating the inverter cable.

    Thanks, and let me know how it goes!

    John
  • Hello John. I did what you recommended and saw that of the four wires of inverter cable it is bad.

    However, even i pushing this little thread, I saw that the piece of plastic that protects the 4 wires, was cracked. Think that broke this part when i removed the old Logic Board.

    I took my Mac in a Apple Authorized Service, but in nothing helped. Those technical seemed inexperienced when it comes
    to Black Screen of Macbook.

    John, I wonder if it's possible the new logic board is defective or is it more likely that the problem is the inverter cable and
    inverter board ???

    Many thanks for your help.
  • Hi! Sorry to hear that. When you say it is bad/cracked, what exactly does it look like? It is normal to be able to see the 4 wires through the top of the connector. Sometimes it's necessary to take a pair of tweezers and push the wires in place, if any of them are not fully seated. And then it is necessary to make sure the connector is fully seated in the socket on the board. You can trying powering on with the topcase off or loose so that you'll be able to adjust the inverter cable and test it.

    It could be the board, but it could also be the inverter cable or the screen. If you want to take a picture of what you are seeing and e-mail it to john@rdklinc.com, I'll let you know what I think of the cable and connector.

    You might just need a new inverter cable if the one you have is damaged. You can find them on eBay by searching for "a1181 3-wall inverter cable".

    Thanks
Sign In or Register to comment.