Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell me your broken computer

Hardware or Software issue? Late-2012 iMac (2544)

edited December 2014 in General
Hi John,

I've exhausted all other corners of the internet looking for an answer to my problem, hopefully you can help! I noticed that all your forums are for apple laptops, iPads, and iPods. Can I ask you about issues with my iMac?

Answers

  • Hi! Thanks for the post! Sure, ask away, and I'll see what I can do. If I can't answer it, someone else might.
  • Great, thanks!

    Ok so I have a Late-2012 iMac, EMC 2544. The original hard drive failed, and I went ahead and replaced it with a Hybrid Drive(Seagate - ST1000LM014). This is when my issues began.

    I put the imac into internet recovery and installed the stock osx 10.8. Upon startup i would have nothing but issues with multiple stock programs, crashing with unexpected errors. Eventually it got to the point where on startup it could not recognize the startup disk and i would force it into disk utility, and the drive could not be verified. I spoke with Seagate and they figured it was a defective drive, so they sent me a new one.

    So after i installed the new drive Seagate had sent me (ST1000LM014), things seemed a bit better than they were, until i attempted to upgrade to yosemite from 10.8 through the app store. Upon running the installer, it would attempt to verify and then tell me "This copy of OSX YOSEMITE installer is corrupt or has been modified...". Invalid checksum. Applications began crashing again, I will include one crash report at the end of this post. After multiple downloads of Yosemite it tells me the same thing. I would clear the cache of the App Store, and redownload, but same thing. I eventually created a boot up partition of the installer on an external hard drive, just to be met with the same error.

    Any thoughts of yours would be greatly appreciated.

    A copy of a crash report, (Just happened with safari while i was typing this:)


    Process: WebProcess [1837]
    Path: /System/Library/PrivateFrameworks/WebKit2.framework/WebProcess.app/Contents/MacOS/WebProcess
    Identifier: com.apple.WebProcess
    Version: 8536 (8536.30.1)
    Build Info: WebKit2-7536030001000000~9
    Code Type: X86-64 (Native)
    Parent Process: Safari [1835]
    User ID: 501

    Date/Time: 2014-12-21 13:57:00.081 -0500
    OS Version: Mac OS X 10.8.5 (12F45)
    Report Version: 10

    Interval Since Last Report: 97220 sec
    Crashes Since Last Report: 89
    Per-App Interval Since Last Report: 6628 sec
    Per-App Crashes Since Last Report: 12
    Anonymous UUID: 97140779-EB86-71D5-F1C5-290C66C7057F

    Crashed Thread: 6 JavaScriptCore::Marking

    Exception Type: EXC_BAD_ACCESS (SIGBUS)
    Exception Codes: KERN_PROTECTION_FAILURE at 0x000000015af037a0

    VM Regions Near 0x15af037a0:
    JS garbage collector 000000015aed4000-000000015af00000 [ 176K] rw-/rwx SM=PRV
    --> JS garbage collector 000000015af00000-000000015af10000 [ 64K] rw-/rwx SM=COW
    JS garbage collector 000000015af10000-000000015af20000 [ 64K] rw-/rwx SM=PRV

    Application Specific Information:
    Bundle controller class:
    BrowserBundleController


    Thread 0:: Dispatch queue: com.apple.main-thread
    0 com.apple.JavaScriptCore 0x00007fff8ef43380 JSC::JSArray::visitChildren(JSC::JSCell*, JSC::SlotVisitor&) + 32
    1 com.apple.JavaScriptCore 0x00007fff8ef8114d JSC::SlotVisitor::drain() + 301
    2 com.apple.JavaScriptCore 0x00007fff8ef80a26 JSC::SlotVisitor::drainFromShared(JSC::SlotVisitor::SharedDrainMode) + 294
    3 com.apple.JavaScriptCore 0x00007fff8ef2a5ce JSC::Heap::markRoots(bool) + 1630
    4 com.apple.JavaScriptCore 0x00007fff8ef29bf8 JSC::Heap::collect(JSC::Heap::SweepToggle) + 152
    5 com.apple.JavaScriptCore 0x00007fff8ef28a0b JSC::DefaultGCActivityCallbackPlatformData::timerDidFire(__CFRunLoopTimer*, void*) + 315
    6 com.apple.CoreFoundation 0x00007fff93b22804 __CFRUNLOOP_IS_CALLING_OUT_TO_A_TIMER_CALLBACK_FUNCTION__ + 20
    7 com.apple.CoreFoundation 0x00007fff93b2231d __CFRunLoopDoTimer + 557
    8 com.apple.CoreFoundation 0x00007fff93b07ad9 __CFRunLoopRun + 1529
    9 com.apple.CoreFoundation 0x00007fff93b070e2 CFRunLoopRunSpecific + 290
    10 com.apple.HIToolbox 0x00007fff92e47eb4 RunCurrentEventLoopInMode + 209
    11 com.apple.HIToolbox 0x00007fff92e47c52 ReceiveNextEventCommon + 356
    12 com.apple.HIToolbox 0x00007fff92e47ae3 BlockUntilNextEventMatchingListInMode + 62
    13 com.apple.AppKit 0x00007fff97daa533 _DPSNextEvent + 685
    14 com.apple.AppKit 0x00007fff97da9df2 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 128
    15 com.apple.AppKit 0x00007fff97da11a3 -[NSApplication run] + 517
    16 com.apple.WebCore 0x00007fff963624ff WebCore::RunLoop::run() + 63
    17 com.apple.WebKit2 0x00007fff8d787462 WebKit::WebProcessMain(WebKit::CommandLine const&) + 2586
    18 com.apple.WebKit2 0x00007fff8d74dbfd WebKitMain + 285
    19 com.apple.WebProcess 0x000000010fd1ae7b 0x10fd1a000 + 3707
    20 libdyld.dylib 0x00007fff8d5bf7e1 start + 1

    Thread 1:: Dispatch queue: com.apple.libdispatch-manager
    0 libsystem_kernel.dylib 0x00007fff90657d16 kevent + 10
    1 libdispatch.dylib 0x00007fff92831dea _dispatch_mgr_invoke + 883
    2 libdispatch.dylib 0x00007fff928319ee _dispatch_mgr_thread + 54

    Thread 2:: com.apple.NSURLConnectionLoader
    0 libsystem_kernel.dylib 0x00007fff90655686 mach_msg_trap + 10
    1 libsystem_kernel.dylib 0x00007fff90654c42 mach_msg + 70
    2 com.apple.CoreFoundation 0x00007fff93b02233 __CFRunLoopServiceMachPort + 195
    3 com.apple.CoreFoundation 0x00007fff93b07916 __CFRunLoopRun + 1078
    4 com.apple.CoreFoundation 0x00007fff93b070e2 CFRunLoopRunSpecific + 290
    5 com.apple.Foundation 0x00007fff977de546 +[NSURLConnection(Loader) _resourceLoadLoop:] + 356
    6 com.apple.Foundation 0x00007fff9783c562 __NSThread__main__ + 1345
    7 libsystem_c.dylib 0x00007fff8e386772 _pthread_start + 327
    8 libsystem_c.dylib 0x00007fff8e3731a1 thread_start + 13

    Thread 3:: WebCore: Scrolling
    0 libsystem_kernel.dylib 0x00007fff90655686 mach_msg_trap + 10
    1 libsystem_kernel.dylib 0x00007fff90654c42 mach_msg + 70
    2 com.apple.CoreFoundation 0x00007fff93b02233 __CFRunLoopServiceMachPort + 195
    3 com.apple.CoreFoundation 0x00007fff93b07916 __CFRunLoopRun + 1078
    4 com.apple.CoreFoundation 0x00007fff93b070e2 CFRunLoopRunSpecific + 290
    5 com.apple.CoreFoundation 0x00007fff93b15dd1 CFRunLoopRun + 97
    6 com.apple.WebCore 0x00007fff963775e1 WebCore::ScrollingThread::initializeRunLoop() + 273
    7 com.apple.JavaScriptCore 0x00007fff8f03325f WTF::wtfThreadEntryPoint(void*) + 15
    8 libsystem_c.dylib 0x00007fff8e386772 _pthread_start + 327
    9 libsystem_c.dylib 0x00007fff8e3731a1 thread_start + 13

    Thread 4:: com.apple.CFSocket.private
    0 libsystem_kernel.dylib 0x00007fff90657322 __select + 10
    1 com.apple.CoreFoundation 0x00007fff93b46f46 __CFSocketManager + 1302
    2 libsystem_c.dylib 0x00007fff8e386772 _pthread_start + 327
    3 libsystem_c.dylib 0x00007fff8e3731a1 thread_start + 13

    Thread 5:: JavaScriptCore::BlockFree
    0 libsystem_kernel.dylib 0x00007fff906570fa __psynch_cvwait + 10
    1 libsystem_c.dylib 0x00007fff8e38afb9 _pthread_cond_wait + 869
    2 com.apple.JavaScriptCore 0x00007fff8edfab66 WTF::ThreadCondition::timedWait(WTF::Mutex&, double) + 118
    3 com.apple.JavaScriptCore 0x00007fff8f01dbfa JSC::BlockAllocator::blockFreeingThreadMain() + 90
    4 com.apple.JavaScriptCore 0x00007fff8f03325f WTF::wtfThreadEntryPoint(void*) + 15
    5 libsystem_c.dylib 0x00007fff8e386772 _pthread_start + 327
    6 libsystem_c.dylib 0x00007fff8e3731a1 thread_start + 13
  • Any ideas where i should start John?
  • edited January 2015
    Hi! First off, sorry for the delay -- I didn't realize that you had posted until I got your reminder e-mail.

    Anyway, I am shooting from the hip here and could be completely wrong but I got a strong hunch reading your post: There are a lot of SSD/hybrid drives that are ATA3 and that exhibit strange behavior like you have described when used on a computer that only has an ATA2 bus. In some cases it can even happen when the computer is ATA3...in these cases it's hard to tell what the source of the problem is. But the primary means of correcting this is to switch the jumper on the drive to downgrade it to ATA2 status, and that generally helps performance. There are some drives that are jumperless and which must be configured in a utility distributed by the manufacturer, and that present difficulty for us Mac users, because the utilities are usually PC-only. Some of these jumperless drives also can benefit from a firmware update to solve the problem, but once again the software which allows for the firmware upgrade is usually PC-only.

    So, first, I would check to see if your drive has jumpers. If not, I'd probably try a different brand drive. I'd buy one from otherworldcomputing.com, a Mac-only company that will be able to recommend a brand/model that they know is 100% compatible.

    I once had a Mac Pro and thought I'd upgrade it to a 3TB ATA3 drive, and I experienced the same type of issues you have. I discovered eventually that if I used it as a backup drive (i.e. anything but a boot drive) it worked fine, so I ended up keeping it as an external drive for backups, and bought another brand drive to be my boot drive. The process of determining what was wrong was maddening, especially since it would work for a while and the issues would build incrementally, which is why I would suggest immediately switching to a known-good brand/model if there isn't a simple jumper fix.

    Anyway, good luck, and let me know what happens!

    John
Sign In or Register to comment.