Howdy, Stranger!

It looks like you're new here. If you want to get involved, click one of these buttons!

Sell your MacBook

start discussion

edited November 2014 in Business
3 beeps when starting up G4 PowerBook

Answers

  • Hi john, great site btw,

    My machine is a G4 PowerBook 15' 1.5Ghz.

    When I try to start up I get 3 small beeps and the sleep light comes on then blinks 3 times then stays solid and repeats. I only have one RAM slot occupied. I've tried changing slots, in the bottom slot I get 1 beep and the top slot I get the 3 beeps.
    Is there anything I can do to solve this problem and get my machine up and running again?
    Would really appreciate any help and advice from you.

    Thanks for your time

    Mark
  • edited November 2014
    Hi Mark! Thanks for the post!

    First off, what PowerBook do you have? Is it a Titanium (black keys), or Aluminum (silver keys)? The last 3 of the serial number will let me look it up as well.

    Also, have you ever seen this laptop work before, and with this RAM? The beeps are generally a RAM issue. The sleep light blinking before booting can also indicate a dead battery (although I don't recall ever seeing that on a PowerBook), so I'd remove the battery to just to eliminate that as part of the issue. If the laptop was ever working while you had it, do you recall any event that occurred between the time of it working and not working?

    You're doing the right thing by testing the slots. Lots of these laptops have slots that end up going bad, and the laptop will not function when a bad slot is populated. Sometimes both slots can go bad, in which case you're out of luck. What are the specs of the RAM (usually printed on the sticker)? Have you tried different RAM? These laptops are also very touchy as far as RAM they will use, even if it is technically compatible RAM.

    Thanks, and once you answer the question I'll have more detailed steps to offer.

    John
  • Hi john

    My mac is the titanium, it worked fine, I used it for producing music. I had a RAM problem before and it was still under warranty so Apple took care of it,I'm assuming all they did was put the RAM in the other port as I'm sure they are in the bottom one as default, and when I opened it after the 2nd issue it was in the upper port.

    I had dropped the laptop, but it worked fine for a while after this happened.

    The RAM Inserted atm is 512mb, and no I haven't tried using different RAM as I thought the issue was the slots? Maybe I'll try this.

    Any other queries as to what the problem might be?

    I was hoping to get back into this machine as it would obviously save me buying a new one

    Thanks
  • Hi Mark!

    You might be experiencing a failure of the other port. I would try different RAM just to rule it out...make sure it's PC133, because although PC100 will fit in the slot, it definitely won't work.

    I would also try the PRAM battery fix, as shown in this video:

    https://www.rdklinc.com/tutorials/TIN6kMixdEs

    I would also try letting the laptop sit overnight disconnected from battery and AC adapter.

    I'd try PRAM and PMU resets, although they probably won't make a difference.

    Beyond that I don't have many other ideas. It couldn't hurt to pop the lower casing off so that you can blow out any dust and see if you spot anything suspicious.

    On the bright side, if you specifically need a Titanium because of PPC compatibility with software, you can probably buy another one fully working on Ebay for $50. You could even upgrade to an aluminum 17" model for around $200.

    Thanks, and let me know how it goes!

    John
  • Appreciate the reply John, I will try all your suggestions.

    Thank you for your time.
Sign In or Register to comment.